All Ubuntu Overview, Ubuntu Main Overview

You are looking at information on the Bazaar importer system that serves Ubuntu Distributed Development. It's hoped that you won't have to care about the existence of this, but things don't always work out that way.

It is expected that uploads appear in the branches in less than 30 minutes, if it takes longer then something is up and this page should tell you why. To discuss issues or to ask for a package to be looked at please use our mailing list ubuntu-distributed-devel@lists.ubuntu.com.

The scripts used to import the packages are available from a bzr branch. If you encounter issues, please file bugs. If you're curious, a detailed explanation about how it works is documented in the UnderTheHood part of the wiki.

This page was last updated at 2018-05-25T20:25:05.124574 UTC.

Failed at 2012-07-04 22:27:01.900229

"Can't find the needed upstream part for version" - bug in importer?

Traceback (most recent call last):
  File "/srv/package-import.canonical.com/new/scripts/bin/import-package", line 5, in <module>
    sys.exit(main(sys.argv))
  File "/srv/package-import.canonical.com/new/scripts/udd/scripts/import_package.py", line 1174, in main
    only_before=options.only_before)
  File "/srv/package-import.canonical.com/new/scripts/udd/scripts/import_package.py", line 1081, in _import_package
    bstore, push, possible_transports=possible_transports)
  File "/srv/package-import.canonical.com/new/scripts/udd/scripts/import_package.py", line 640, in import_package
    use_time_from_changelog=True)
  File "/srv/package-import.canonical.com/new/scripts/plugins/builddeb/import_dsc.py", line 1243, in import_package
    pull_debian=pull_debian)
  File "/srv/package-import.canonical.com/new/scripts/plugins/builddeb/import_dsc.py", line 1122, in _import_normal_package
    self.pull_version_from_branch(pull_branch, package, version)
  File "/srv/package-import.canonical.com/new/scripts/plugins/builddeb/import_dsc.py", line 722, in pull_version_from_branch
    "for version %s" % version)
AssertionError: Can't find the needed upstream part for version 0.87.2-1

Packages with this issue